Upgrading the Website's PHP Version

At the moment, MailPoet requires PHP version 5.6 or higher. Soon we will require PHP version 7 or higher. We strongly recommend upgrading to PHP 7.2.

Support for version 5.6 will continue until next year, although older versions of PHP won't be supported by our plugin and MailPoet might not work well in those cases.

Some of them have already reached the "end of life". For example, PHP version 5.6 security updates will only be provided until the end of 2018 and PHP 7 will only receive security updates until 3rd December 2018.

Guides to Upgrade PHP versions

Your host will provide you with the necessary guide to upgrade.

If your host is not listed, please contact their technical support and ask for your PHP version to be updated. If they're unable to help you, consider changing hosts. Hosts make it easy today to switch.

It's Risk Free Because You Can Instantly Revert

If something goes wrong on your website:

  • Simply revert to the previous PHP version;
  • If you want to try to figure out the problem, find which plugins might be the cause by disabling all of them, one-by-one. Look for plugins that have not been updated in the last 6 months;
  • Try a different theme too. Make sure your own theme has been updated recently;
  • Hire someone to help you in this process if you prefer to have someone else deal with it. We recommend freelancers on codeable.io;
  • Ask your host for help. A good host will be able to help you.

Determine Your PHP Version

Install this simple plugin on your website to determine your PHP version.

Contact our support if you have any other questions.